Information related to: Microsoft - Cisco - Ubiquiti - MikroTik - TP-Link - Linux - Networking - IT - RedHat - Support
Creating Site‐to‐Site VPNs with Pre‐Shared Keys @ Cisco Router
1. Document your IKE Phase 1 negotiation criteria (example below)
• Hashing: SHA‐1
• Authentication: pre‐shared
• Key exchange: Diffie‐Hellman Group 2
2. Document your IPSec (IKE Phase 2) negotiation criteria (example below)
• Encryption algorithm: esp‐aes 128
• Authentication: esp‐sha‐hmac
Configuring IKE Phase 1:
1. Enable ISAKMP
• Router(config)#crypto isakmp enable
2. Create ISAKMP Policy : Router(config)#crypto isakmp policy <1-10000>
• Router(config)#crypto isakmp policy 100
• Router(config-isakmp)#encryption aes 128
• Router(config-isakmp)#authentication pre-share
• Router(config-isakmp)#group 2
• Router(config-isakmp)#hash sha
• Router(config-isakmp)#exit
3. Configure ISAKMP Identity: Router(config)#crypto isakmp identity <address/hostname>
• Router(config)#crypto isakmp identity address
4. Configure ISAKMP Key: Router(config)#crypto isakmp key 0 <Pre-Shared-Key> address <remote IP address>
• Router(config)#crypto isakmp key 0 SUPERSECRETKEY address 1.1.1.2
Configuring IKE Phase 2:
1. Create transform sets: Router(config)#crypto ipsec transform-set <name> <methods>
• Router(config)#crypto ipsec transform-set SET-NAME esp-aes128 esp-sha-hmac
• Router(cfg-crypto-trans)#mode tunnel
• Router(cfg-crypto-trans)#exit
2. (optional) Configure IPSec lifetime : Router(config)#crypto ipsec securityassociation lifetime <seconds/kilobytes> <value>
• Router(config)#crypto ipsec security-association lifetime seconds 86400
3. Create mirrored ACLs defining traffic to be encrypted and the traffic expected to be received encrypted. Router(config)#ip access-list extended <name>,
Router(config)#permit ip <source network | wildcard> <destination network | wildcard>
• Router(config)#ip access-list extended S2S-VPN-TRAFFIC
• Router(config-ext-nacl)#permit ip 172.30.2.0 0.0.0.255 192.168.1.0 0.0.0.255
• Router(config-ext-nacl)#exit
4. Set up IPSec crypto‐map : Router(config)#crypto map <name> <seq> ipseciskmp
• Router(config)#crypto map S2S-VPN 100 ipsec-isakmp
o Router(config-crypto-map)#match address S2S-VPNTRAFFIC
o Router(config-crypto-map)#set peer 1.1.1.2 <remote IP>
o Router(config-crypto-map)#set pfs group2 <group1/2/5optional>
o Router(config-crypto-map)#set transform-set SET-NAME<set>
Apply to Interface:
1. Apply crypto‐map to interface
• Router(config)#int fa4
• Router(config-int)#crypto map S2S-VPN
Create Interesting Traffic:
1. Ping from source network to destination network.
Verify:
2. Show and debug commands (QM_IDLE is good)
• Router#show crypto isakmp sa
• Router#show crypto ipsec sa
• Router#debug crypto isakmp
• Router#debug crypto ipsec
• Router#show crypto map
• Router#show crypto isakmp policy
• Router#show crypto ipsec transform-set
• Router#clear crypto sa
Summary of telnet commands
To ... Do this ...
Connect to a remote system telnet> open remote_system_name Suspend a telnet connection Ctrl ] and return to the telnet prompt Close a connection to a Ctrl ] remote system telnet> close**Suspend telnet and work on telnet> z the local system **Resume the use of telnet prompt% fg telnet> End the telnet session telnet> quit To display a list of telnet telnet> ? commands To get an explanation of a telnet> help name_of_command command
** These commands only work if you are using the C shell, Korn shell, TC shell or BASH shell.
Invitation to Grooveshark
|
642-617 Deploying Cisco ASA Firewall Solutions Exam Topics (Blueprint)
The 642-617 Deploying Cisco ASA Firewall Solutions (FIREWALL v1.0) exam is associated with the CCSP, CCNP Security and Cisco Firewall Specialist certifications. This exam tests a candidate's knowledge and skills needed to implement and maintain Cisco ASA-based perimeter solutions. Successful graduates will be able to reduce risk to the IT infrastructure and applications using Cisco ASA features, and provide detailed operations support for the Cisco ASA. Candidates can prepare for this exam by taking the Deploying Cisco ASA Firewall Solutions course.
Exam Topics
The following information provides general guidelines for the content likely to be included on the exam. However, other related topics may also appear on any specific delivery of the exam. In order to better reflect the contents of the exam and for clarity purposes the guidelines below may change at any time without notice.
Pre-Production Design
Choose ASA Perimeter Security technologies/features to implement HLD based on given security requirements
Choose the correct ASA model to implement HLD based on given performance requirements
Create and test initial ASA appliance configurations using CLI
Determine which ASA licenses will be required based on given requirements
Complex Operations Support
Optimize ASA Perimeter Security features performance, functions, and configurations
Create complex ASA security perimeter policies such as ACLs, NAT/PAT, L3/L4/L7 stateful inspections, QoS policies, cut-thru proxy, threat detection, botnet detection/filter using CLI and/or ASDM
Perform initial setup on the AIP-SSM and CSC-SSM using CLI and/or ASDM
Configure, verify and troubleshoot High Availability ASAs (A/S and A/A FO) operations using CLI and/or ASDM
Configure, verify and troubleshoot static routing and dynamic routing protocols on the ASA using CLI and/or ASDM
Configure, verify and troubleshoot ASA transparent firewall operations using CLI
Configure, verify and troubleshoot management access/protocols on the ASA using CLI and/or ASDM
Describe Advanced Troubleshooting
Advanced ASA security perimeter configuraiton/software/hardware troubleshooting using CLI and/or ASD fault finding and repairing
Certificaciones de Microsoft
Estos grupos, según el site de certificaciones oficial, son:
Microsoft Office
Server and Windows Technologies
Developer tools and applications
Windows client
Microsoft Dynamics
Security and other solutions
De las certificaciones que nos ocuparemos en este post es de las dos más comunes que se desprenden del grupo Server and Windows Technologies:
MCITP (Microsoft Certified IT Professional): Server Administrator (antes llamada MCSA: Microsoft Certified Systems Administrator)
MCITP (Microsoft Certified IT Professional): Enterprise Administrator (antes llamada MCSE: Microsoft Certified Systems Engineer)
Cabe aclarar, que desde hace algún tiempo, cada examen nos otorga una certificación como especialista en la tecnología específica que rendimos, éstas certificaciones se llaman Microsoft Certified Technology Specialist (MCTS).
Podemos consultar todas las certificaciones MCTS acá.
Ahora bien, en lo que uno generalmente se confunde es en los números y nombres de los cursos, exámenes, certificaciones y libros. Veamos:
Uno puede certificarse sin hacer ningún curso. Para esto, debe registrarse en www.prometric.com y sacar un turno en alguno de los Centros Autorizados que Prometric nos indica en nuestra zona.
Hasta acá todo bárbaro, ahora aclaremos qué exámenes son necesarios para obtener las dos certificaciones enumeradas arriba (MCITP: SA y MCITP: EA).
--------------------------------------------------------------------------------
Para MCITP: SA:
Examen 70-640 (Windows Server 2008 Active Directory, Configuring)
Examen 70-642 (Windows Server 2008 Network Infrastructure, Configuring)
Examen 70-646 (Windows Server 2008, Server Administrator)
--------------------------------------------------------------------------------
Para MCITP: EA:
Examen 70-640 (Windows Server 2008 Active Directory, Configuring)
Examen 70-642 (Windows Server 2008 Network Infrastructure, Configuring)
Examen 70-643 (Windows Server 2008 Applications Infrastructure, Configuring)
Examen 70-647 (Windows Server 2008, Enterprise Administrator)
más sólo uno de los siguientes:
Examen 70-620 (Configuring Microsoft Windows Vista Client)
Examen 70-680 (Windows 7, Configuring)
Examen 70-681 (Windows 7 and Office 2010, Deploying)
--------------------------------------------------------------------------------
Ahora que ya entendimos qué exámenes tenemos que rendir para obtener las certificaciones profesionales, expliquemos qué son las MCTS (Microsoft Certified Technology Specialist).
Como comentamos más arriba, estas certificaciones las obtenemos con cada examen que rendimos (no con todos, solo los que Microsoft indica como TS).
Veamos qué certificaciones obtenemos con cada uno de los exámenes necesarios para las dos carreras que estamos viendo:
--------------------------------------------------------------------------------
Para MCITP: SA:
Examen Certificación obtenida
70-640 MCTS: Windows Server 2008 Active Directory, Configuration
70-642 MCTS: Windows Server 2008 Network Infrastructure, Configuring
70-646 Ninguna.
--------------------------------------------------------------------------------
Para MCITP: EA:
Examen Certificación obtenida
70-640 MCTS: Windows Server 2008 Active Directory, Configuration
70-642 MCTS: Windows Server 2008 Network Infrastructure, Configuring
70-643 MCTS: Windows Server 2008 Applications Infrastructure, Configuring
70-647 Ninguna.
70-620 MCTS: Configuring Microsoft Windows Vista Client
70-680 MCTS: Windows 7, Configuring
70-681 MCTS: Windows 7 and Office 2010, Deploying
--------------------------------------------------------------------------------
Es decir, que si rendimos los exámenes necesarios para convertirnos en MCITP: Server Administrator, obtenemos 3 certificaciones:
MCTS: Windows Server 2008 Active Directory, Configuration
MCTS: Windows Server 2008 Network Infrastructure, Configuring
MCITP: SA
y para MCITP: Enterprise Administrator obtenemos 5 certificaciones:
MCTS: Windows Server 2008 Active Directory, Configuration
MCTS: Windows Server 2008 Network Infrastructure, Configuring
MCTS: Windows Server 2008 Applications Infrastructure, Configuring
MCITP: EA
Una de éstas:
MCTS: Configuring Microsoft Windows Vista Client
MCTS: Windows 7, Configuring
MCTS: Windows 7 and Office 2010, Deploying
--------------------------------------------------------------------------------
Bien, sigamos. Vamos ahora con los cursos. Éstos se denominan Microsoft Official Course (MOC).
Generalmente uno se inclina a realizar los cursos para luego rendir los exámenes y obtener las ansiadas certificaciones y se encuentra con que los cursos sirven para varias certificaciones, que un examen abarca el temario de más de un curso y que los cursos también tienen nomenclatura numerada!
Para esto, vamos a ver también claramente qué cursos comprenden cada examen (y por transitividad, cuáles para cada certificación).
--------------------------------------------------------------------------------
Para MCITP: SA:
Examen Cursos que contiene
70-640 MOC 6425 - Configuring and Troubleshooting Windows Server® 2008 Active Directory Domain Services.
MOC 6426 - Configuring and Troubleshooting Identity and Access Solutions with Windows Server 2008 Active Directory
70-642 MOC 6420 - Fundamentals of Windows Server 2008 Network Infrastructure and Application Platform
MOC 6421 - Configuring and Troubleshooting a Windows Server 2008 Network Infrastructure
70-646 MOC 6430 - Planning and Administering Windows Server 2008 Servers
--------------------------------------------------------------------------------
Para MCITP: EA:
Examen Cursos que contiene
70-640 MOC 6425 - Configuring and Troubleshooting Windows Server® 2008 Active Directory Domain Services.
MOC 6426 - Configuring and Troubleshooting Identity and Access Solutions with Windows Server 2008 Active Directory
70-642 MOC 6420 - Fundamentals of Windows Server 2008 Network Infrastructure and Application Platform
MOC 6421 - Configuring and Troubleshooting a Windows Server 2008 Network Infrastructure
70-643 MOC 6428 - Configuring and Troubleshooting Windows Server 2008 Terminal Services
MOC 6418 - Deploying Windows Server 2008
MOC 6427 - Configuring and Troubleshooting Internet Information Services in Windows Server 2008
70-647 MOC 6437 - Designing a Windows Server 2008 Applications Infrastructure
MOC 6435 - Designing a Windows Server 2008 Network Infrastructure
MOC 6436 - Designing a Windows Server 2008 Active Directory Infrastructure and Services
70-620 MOC 5115 - Installing and Configuring the windows vista operating system
70-680 MOC 6292 - Installing and Configuring Windows 7 Client
70-681 No hay cursos por el momento
--------------------------------------------------------------------------------
Algo que también pueden notar en la numeración de los cursos es que terminan con diferentes letras, éstas indican el “ciclo de vida” de los cursos, es decir que el MOC 6420AK tiene material más nuevo y corregido que el MOC 6420A.
Espero que este post sirva para dar un poco de luz a algo que en principio nos espanta con tantos números y caminos posibles.